Python Error: zipimport.zipimporterror can't decompress data zlib not available

zipimport.zipimporterror can't decompress data zlib not available

This error happens because of the absence of zlib libraries in the system and can be solved by installing the same.

For Ubuntu/Debian servers,

#apt install zlib1g-dev 

For Centos/Redhat servers,

#yum install zlib-devel

Please note that the recompilation of Python is required after this zlib installation if Python is custom installed.

That's all…