Error: Ignoring ensurepip failure: pip 8.1.1 requires SSL/TLS

Sometimes we will get the following error while installation Python modules using pip.


Ignoring ensurepip failure: pip 8.1.1 requires SSL/TLS


This is because of the system don't have the SSL development dependencies.

We can resolve this problem by installing the following dependencies.

For Ubuntu,

apt-get install libssl-dev
apt-get install make build-essential libssl-dev zlib1g-dev libbz2-dev libsqlite3-dev

For Centos,

yum install openssl-devel
yum install zlib-devel bzip2-devel sqlite sqlite-devel openssl-devel

 

Leave a Reply

Your email address will not be published. Required fields are marked *