CentOS6 Error: Eg. Invalid release/repo/arch combination/

Eg. Invalid release/repo/arch combination/

This error is due to CentOS6 reaching its End Of Life and no longer supported. The best way to solve this problem is that to updagrade the server to CentOS versions like CentOS 7 or CentOS 8.

If its not possible, we can use one alternate way to resolve the error.

Step1: Open the CentOS-Base.repo file.

#vi /etc/yum.repos.d/CentOS-Base.repo

Step2: Remove the existing content and save the below lines.

[Base]
name=CentOS-6.10 - Base
baseurl=http://vault.centos.org/6.10/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
enabled=1  
metadata_expire=never

[Updates]
name=CentOS-6.10 - Updates
baseurl=http://vault.centos.org/6.10/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
enabled=1
metadata_expire=never

[Extras]
name=CentOS-6.10 - Extras
baseurl=http://vault.centos.org/6.10/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
enabled=1
metadata_expire=never

[Contrib]
name=CentOS-6.10 - Contrib
baseurl=http://vault.centos.org/6.10/contrib/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
enabled=0
metadata_expire=never

[Centosplus]
name=CentOS-6.10 - CentOSPlus
baseurl=http://vault.centos.org/6.10/centosplus/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
enabled=0
metadata_expire=never

Now we can install packaged without any issues.

Please note that Vault repo is a place that provides the access to older archived versions and they are not providing any security updates. So use this as a temporary solution and upgrade the server for the permanent solution.

That's all…